astray,

Or the crack was an in-house job and they are just using the in-house patch to get around it.

quackers,

Or its just a piracy check…

balls_expert,

Imagine if they distributed one of those that contained a strange bind syscall somewhere with a reverse shell.

sounddrill,

They probably already do

Empress for sure at least.

HawlSera,

Not the first time, won’t be the last.

pewgar_seemsimandroid,

no breath

SeedyOne,

Remember that time a random player DRAMATICALLY decreased load times for GTA online after finding bad code that preloaded TONS of game assets? After like, a decade?

Pepperidge Farm remembers…

sdw,
chetradley,

Good on R* for fixing the bug and paying the bounty. Nintendo would’ve given him the middle finger and a cease and desist.

glibg10b,
SeedyOne,

That’s the one! Thanks for the link.

JackbyDev,

Are you talking about the guy that found a bug in the JSON parsing?

cordlesslamp,

Are you saying the INSANE GTA Online load time is fixed now?

Back in the old day, I literally just throw my hands up and said “I can’t wait for this shit anymore, I don’t have all day” then rage quit and delete the game.

SeedyOne,

Yep. I’d long quit the game when they finally figured it out.

dangblingus,

Rockstar paid the guy like 50K or something for discovering it, and then it was apparently implemented into GTA online. Too bad I quit playing that time black hole years ago.

cordlesslamp,

I watched a YT video about this and they said the guy was paid 10K (way too low imo), a Google search shows different numbers everywhere so it’s hard to confirm. But at least the guy got paid, for sure.

As far as I’m understanding it, the game was using a single threading process to load every single items in the game one by one (over 10 thousands in total), then checking again for duplicate.

cloud,

What i’m looking at? What is this from?

wahming,

Hidden text within the app code from the steam folder

cloud,

So the official files contains a razor 1911 line? This look sus af

wahming,

In what sense? Incompetence, dodginess, or fake screenshot?

u202307011927,

Anyone know what RAZOR 1911 stands for or means, anyways?

naught,

It’s a group that cracks stuff for 🏴‍☠️

enki,

What a fucking nostalgia bomb. Haven’t been a part of the scene for a very long time, so seeing RAZOR 1911 in the hex triggered a flashback. They were huge back when I was running a “warez” BBS as a kid in the 90s.

Klear,

Good old dos game cracks bundles with funky demos.

melroy,
@melroy@kbin.melroy.org avatar

1911 which translates to 777 in hexadecimal.

melroy,
@melroy@kbin.melroy.org avatar

In Unix's chmod, change-access-mode command, the octal value 777 grants all file-access permissions to all user types in a file.

melroy,
@melroy@kbin.melroy.org avatar

Within the binary of the file *

wahming,

Yes, I was trying to keep it to a non-technical ELI5

melroy,
@melroy@kbin.melroy.org avatar

Let's educate the world 🌍🎉

AlboTheGuy,
@AlboTheGuy@feddit.nl avatar

To be fair, if you don’t know what that is at a glance you probably don’t know what the binary of a file is either

merc,

When you view or edit a text (.txt) file in a text editor like Notepad, you’re most often opening a file in ASCII encoding that uses the ASCII binary values for common letters, numbers and punctuation. The only values allowed in that kind of file are lowercase letters, uppercase letters, numbers and punctuation.

You can also view or edit binary files, like executables (.exe), but you typically need a hex editor. If you tried to open a binary file in a plain text editor it wouldn’t know how to handle all the binary values that are not part of the standard ASCII set of letters, numbers and punctuation.

Hex editors show the data in hexadecimal format. They convert the binary data to numbers from 0 to 15 where the numbers 10 to 15 are replaced by the letters A to F. Often to make it clear people are talking about the hex number they add “0x” in front of the number. So, 0 becomes 0x0, 9 becomes 0x9, 15 becomes 0xF, 16 becomes 0x10, and 255 becomes 0xFF. This is an efficient way for people to work with binary data because 16 is 2^4^ or 222*2.

Within binary files, there will still be a lot of sections that are in ASCII. For example, any error messages that have to be printed out for the user to see, like “this program cannot be operated in DOS mode”.

Razor 1911 is an infamous cracker group that has been around for decades. They often “sign” the programs they crack by putting “Razor 1911” inside the files, in a way where you can see it if you open it with a hex editor, but so it doesn’t affect the program.

So, what this is suggesting is that a program that Rockstar has released on Steam is not something they built themselves, but they’re actually distributing a cracked version that was released by Razor 1911.

Damage,

Vestigial DNA

tun,

It means cracker fixed the issue for the developer, right?

Ganbat,

It means the publisher was too lazy/greedy to remove their ancient DRM themselves and just nabbed the work someone else did, slapped Steam Stub on top and sold it.

ninjan,

I love the implication here, that they don’t have the proper source (or skills left in the company) such that they can remove the DRM which doesn’t play nice themselves so they rely on a cracked copy of the game instead. Been quite a bit of news lately about how game companies have failed to keep the original source code for their games. Diablo 2, the Transformers games etc and those from active companies, there’s bound to be 1000s of games where the source is lost due to publishers closing down studios.

lemann,

It’s a complete crapshow IMO.

I still have the source code for the simple stuff I developed over 12 years ago, but these organisations don’t think it’s important to hang on to source code and assets for something they plan to make money from?

Really telling about the attitudes towards software outside of the FOSS space and datahoarder communities, and more importantly how little the management/publishers actually care about the product.

Although to counter that, I’m aware of at least one situation where the opposite has happened. One of my simulation games for example is really buggy and isn’t able to receive more updates because the studio behind it voluntarily disbanded, leaving the publisher without access to the source code (I believe the publisher Aerosoft has tried to get a copy of the source to provide further game fixes, but the individuals behind the disbanded studio could not come to an agreement on this)

JackbyDev,

I’ve had teams not bother to keep proper history when moving from subversion to git and I’ve also had a DevOps team entirely wipe the history of a new project just because cloning took a long time (and refused to attempt shallow cloning).

So the idea that a company just lets their code “rot” to the point of not even having it anymore because it’s just some legacy thing from over a decade ago is totally unsurprising to me.

rolaulten,

Just to pile on. I’ve seen devs throw out the entire git history when moving between repos for ongoing projects.

Teppic,
@Teppic@kbin.social avatar

Logical next step, hacker sues the developer for copyright infringement?

planish,

The crack might not actually be protected by copyright, unless there’s substantial new code added.

VieuxQueb,
@VieuxQueb@lemmy.ca avatar

I mean, they didn’t even bother to remove the signature!

EnderofGames,

I don't know about Diablo 2, but Blizzard is so shady and messed up nowadays that I wouldn't be surprised that they "lost the source code" to prevent modders being able to port games, etc.

As for transformers, it was never lost (PCGamer, if you don't like Xfire). Hasbro claimed they wanted to provide access to legacy games, but completely made up that the source was lost. Now that we know that the source is still available... well, Hasbro clearly hasn't tried to rerelease those games.

(note: I know this is the same company, Activision Blizzard in both cases. For anyone reading who doesn't know, they were not the same company for the release of Diablo II, and a good amount of time afterwards.)

Ganbat,

I’d say they probably still have the source. It looks like they did the same thing for Manhunt and Max Payne, but then pulled older, pre-SecuROM exes from their archives when they got busted.

rektifier,

Even if they have the source, they may not have all the build tools anymore.

Or they have the build tools but the wizard that set up the build system back in the day no longer works there.

Or they have the build system archived and documented but it doesn’t run because some license expired, and the tool vender doesn’t sell that version anymore.

In the near future, there will be another possibility - SaaS cloud tools that are impossible to preserve so they are forever lost.

ninjan,

Very true, and even if they could replace/remove libraries and dependencies that muck up the build process there are no guarantees that it’ll play the same. So many games rely on strange quirks to function the way they do that would be nigh impossible to replicate purposely.

Ganbat,

Better than their in-house attempts to remove anti-piracy measures. The Steam release of Manhunt has had all of its bullshit triggered for over ten years now. It’s literally impossible to play without community patches.

Edit: Lol, as it turns out, Silent’s discovery of this was triggered by the recent revelation of this about Manhunt!

JokeDeity,

I spent hours trying to get that fucking game to work…

Ganbat, (edited )

Sad fact is, Rockstar doesn’t give a shit. They got busted using a cracked EXE in the Steam release, so they just tried to cover their asses by using an old EXE without SecuROM. I expect the same thing from this game before long.

Couple lucky things for the players, though. First off, the Razor 1911 crack is still in the files, they just renamed it to testapp. Second, old RS games have a dedicated community that give way more of a shit about them than Rockstar ever will. Silent and Fire Head have both released major patches for Manhunt that not only get it running right, but fix a bunch of other broken shit that Rockstar never cared enough to deal with.

SternburgExport,

Doesn’t even surprise me anymore. Rockstar has gone to shit.

Oha,
@Oha@lemmy.ohaa.xyz avatar

cant even play their legitly purchased SINGLEPLAYER games without internet connection.
I fucking hate rockstar

Infiltrated_ad8271,
@Infiltrated_ad8271@kbin.social avatar

Sometimes there is a trick that allows to play offline (I guess to bypass tags and restrictions), things like adding a line of text to a file, always a hassle and poorly documented.

Btw, I feel like telling that I deleted my rockstar account quite a while ago, they asked and re-asked nonsense, waiting from weeks to over a month between email and email, and the worst thing is that sometimes they were in chinese. It took me more than half a year to delete that crap.

glibg10b,

Sometimes there is a trick that allows to play offline (I guess to bypass tags and restrictions), things like adding a line of text to a file, always a hassle and poorly documented.

Pirating the game is a lot easier. The people getting punished are the ones who give Rockstar their money

SternburgExport,

Wait… WHAT?

Oha,
@Oha@lemmy.ohaa.xyz avatar
SternburgExport,

I’m already angry enough that they don’t let me spawn certain vehicles in singleplayer but this is too much. Time to get a cracked version and uninstall that Rockstar Launcher crap.

XEAL,

Source’s source: https://twitter.com/_

wallmenis, (edited )

The nitter link: https://nitter.net/_

Devjavu,

Might wanna fix that

TWeaK,

Fix what? Link works fine for me. Sometimes Nitter doesn’t load though, hit refresh a few times and you’ll get it.

Ganbat,

Because it’s a bare link, some apps interpret the underscore as the end of the link.

TWeaK,

Ah right I see. Surely that’s the app developer’s responsibility to fix?

pjhenry1216, (edited )

"I see a problem I can easily fix but obviously it's someone else's problem."

Here's the full link.

https://nitter.net/_

Edit: to lemmy users, this link looks no different. To third party app users and Kbin users, etc, the previous links all cut out after the first underscore.

TWeaK,

I mean sure, but that’s a bit more involved than just pasting a link with no code and having the renderer make a link, which lemmy is supposed to do. The app is failing to meet the lemmy spec, the developer should fix that.

pjhenry1216,

So, it's actually more a Lemmy bug. Lemmy stores the comments just fine but the API displays it with markdown. The double underscore is screwing up other apps abilities to display it and there's really no way to avoid that. A third party app can't tell if it's supposed to be interpreted or not.

So on Lemmy, all the URLs look fine. On Kbin or any other apps, they'll all get cut off after the first underscore.

TWeaK, (edited )

and there’s really no way to avoid that.

Yes there is, the way lemmy avoids it. _ might be usable as a tag in mark down, but it shouldn’t be used to break out of a URL.

This is definitely a kbin bug lol. Edit: not kbin, but whichever app people are browsing with. Both lemmy and kbin websites work.

pjhenry1216,

Lemmy avoids it by having the source content and then translating output to markdown. Any third party reader needs to sanitize that output.

Lemmy basically does not output safe content for third parties. It's absolutely a Lemmy bug from any developer's perspective.

TWeaK,

I’ve just checked on kbin and the link works just fine. Kbin doesn’t display the full link, but when you click it on the website it works.

Are you using an app to browse kbin? In that case it’s your app that’s not doing it correctly. Possibly kbin doesn’t give it the infomration, or maybe it just reads the text of the link and misuses that.

Either way, the problem is nothing to do with lemmy. However lemmy apps have their own little bugs to work out (eg instance agnostic links from v0.18) so we’re all in the same boat of fedeverse development.

pjhenry1216, (edited )

The link works for me. I was helping other folks who may have an issue with bare links as pointed out by the other commenter.

Either way, Lemmy is the reason non-lemmy readers can't actually properly parse the information. The information is not what's stored in the database. Only Lemmy can display it properly since it wraps it up in a bunch of markup that is then provided to third parties. As a developer, I don't know what reasoning you still think you have to believe it's not Lemmy. Everything you've said so far does nothing to backup that point.

Edit: also, I'm done here. I'm not interested in convincing a non-developer their favorite platform isn't perfect.

TWeaK, (edited )

Edit: to lemmy users, this link looks no different. To third party app users and Kbin users, etc, the previous links all cut out after the first underscore.

The link works for me.

So which is it? Did it work or not?

When I checked, it worked. Before the link was edited, when it was just a raw url with no markdown code. Lemmy dispayed the full link with the underscores. Kbin displayed a shortened version, but it linked to the same url.

You’re being incredibly pretentious with this “I’m a developer” nonsense. A developer of what? Be specific. Which app did you actually see the problem in?

Either way, you’ve been the one trying to push the blame on lemmy and users, right from the start. I’m not really sure what you’re playing at here, but it seems like you’ve realised your mistake and are now trying to save face.

The issue is with your app. Both lemmy and kbin desktop websites parsed the url correctly.

Here it is again for testing: nitter.net/_

Edit: Works fine on lemmy and kbin websites, doesn’t work in Jerboa. So it’s yet another problem with Jerboa (or whichever app) text processing, nothing to do with lemmy and certainly not the user’s fault.

“I see a problem I can easily fix but obviously it’s someone else’s problem.”

Incredibly pretentious. Sort yourself out mate.

pjhenry1216,

Before the link was edited, when it was just a raw url with no markdown code.

It's always with markdown. Lemmy is the only web app that can access it without markdown. I explained it like four different ways now. If you don't understand it by now, you never will.

It worked for me and it's why I provided a full link. Since it was created on Kbin, it was escaped by Lemmy as well. So lemmy will display the app just like Kbin would. But anyone who creates a link on lemmy, it will always look wrong in every other web app or third party app. It's simply not possible for a third party app to display a link properly that was created by a lemmy user. Same goes for code boxes. They can only be displayed properly by Lemmy and no one else. It's not possible for third party apps to display them properly.

Lemmy is the only one that can display links and code boxes created by Lemmy users. Links and code boxes created by every other platform displays properly everywhere.

You're literally hand waving it away because it still works even though it's impossible to parse by any other app. Just because it is only aesthetic doesn't mean it's a bug. The bug affects jerboa more than Kbin. I still helped those users instead of your pretentious ass by saying "oh well, not my problem."

When there's a problem that only exists with lemmy, it's lemmy.

Do you need me to explain it yet another way? Do you need an ELI5?

You're the pretentious one speaking from some authority without having any clue what the fuck you're talking about.

I'm done. You're blocked so I won't be angered by any stupid replies from you.

TWeaK, (edited )

Same goes for code boxes. They can only be displayed properly by Lemmy and no one else. It’s not possible for third party apps to display them properly.

Except Jerboa displays code tags just fine. There’s also the view source function.

There are ways to solve the problem, they just haven’t been implemented yet. That’s up to app developers.

I’m done. You’re blocked so I won’t be angered by any stupid replies from you.

Shock horror. Something tells me they don’t need me to get angered.

Edit: So, thinking on it some more for the benefit of anyone else, it would be perfectly possible to fix in Jerboa for lemmy. Jerboa just breaks out of the link but still shows the full url, only the rest of it is text and the bit in between two removed _ is italicised. Jerboa is failing to inhibit for the link and applying markdown to it.

Maybe on kbin apps it can’t work, because kbin shortens the link in text and doesn’t have a view source function. But kbin is not lemmy.

Rai,

Thank you! Now it’s clickable for me.

wallmenis,

How? I read the comments and I can’t replicate the issue you are experiencing. The original link is causing the problem for me (but I can still access the page).

CorrodedCranium,
@CorrodedCranium@leminal.space avatar
lemann,

I’ll just stick to 🏴‍☠️ old games with DRM, why should I give a company 🤑 for redistributing a cracker’s hard work?

XEAL,

You gotta do a workaround url when the URL breaks like that.

wallmenis,

Thank you! Imma fix it right now.

user224,
@user224@lemmy.sdf.org avatar
TWeaK,

It’s not really a crack, it’s the corporate activation script. But yeah, MS don’t care about sales anymore, they’re all about stealing your data.

pjhenry1216,

The information the OS collects is not worth more than keeping you in the ecosystem itself. That's the more lucrative reasoning. Can't easily sell other products if they're not in Windows. The information collection is just gravy.

Daqu,

They just want everyone to have Windows at home, so that it keeps being the “normal” OS for corporations. They make so much money… Windows+ CALs, Office, Exchange, Sharepoint, M365, Azure… it’s easier to keep paying them, than to change vendors.

rolaulten,

So counter point. Active directory is a god send for managing endpoints, user accounts, endpoints, etc.

No you don’t let windows act as a dns server outside the ad subdomain, no you don’t use windows to admin your root private ca, and for all you hold dear do not enable that God forsaken web server. But for what it does well, it’s the best solution out there.

ours,

Or Ubisoft. A colleague of mine was super hyped for Far Cry 2, both the collector’s edition but it wouldn’t start on his PC. He contacted Ubisoft support and they gave him an actual scene crack. There were other reported cases of Ubisoft support handing out scene cracks to go around their shitty DRM.

“A” for effort for the support people in finding ways for customers to be happy and play the games they paid for. But a Steam release for a humongous corporation just straight up using the crack and releasing it as is, that’s a new low.

nosurprises,

I wouldn’t be here if I wanted to go on reddit. Moreover, the reddit post is not even the initial source of the information.

VikingHippie,

The initial source (or at least the one linked to in the reddit post) is the vastly inferior microblogging version of xvideos though, so skipping reddit would have been even worse 🤷

z3n0x,
@z3n0x@feddit.de avatar

enshittification all the way down

VikingHippie,

Yup!

000999,

True, every time I click one of those links it tries to make me make an account

VikingHippie,

I technically have an account, but I haven’t logged into it since a month or so after Musk started destroying it.

The final straw was getting banned for a full week for “hate speech” just for pointing out that Bill Burr probably wouldn’t want to participate in a Tucker Carlson “special report” about how “humor isn’t allowed anymore”, nor give permission for clips of him to be included in a promo for it 🤦

glibg10b,

I would be content with a screenshot of that xvideos microblog

Klear,

Make it a screenshot from the xvideos microblog posted on reddit and then screenshotted again.

Ubermeisters,

Wahhhhhh

  • All
  • Subscribed
  • Moderated
  • Favorites
  • Blogi
  • sport
  • lieratura
  • esport
  • Cyfryzacja
  • giereczkowo
  • rowery
  • Spoleczenstwo
  • kino
  • piracy@lemmy.dbzer0.com
  • muzyka
  • LGBTQIAP
  • opowiadania
  • Pozytywnie
  • slask
  • Psychologia
  • motoryzacja
  • turystyka
  • MiddleEast
  • krakow
  • fediversum
  • zebynieucieklo
  • test1
  • Archiwum
  • niusy
  • FromSilesiaToPolesia
  • NomadOffgrid
  • m0biTech
  • goranko
  • All magazines